Excel Avançado: Trabalhando com Condições (Planilha de Controle de Vendas)

AGRADEÇA AO AUTOR COMPARTILHE!

Olá, amigos!

Continuando com os tutoriais baseados no pacote Office da Microsoft, iremos abordar neste aqui sobre a poderosa planilha de cálculo da Microsoft, o Excel.

Aqui vou mostrar como criar uma planilha de cálculo para controle de vendas. Uma ou outra coluna até não seria necessária aqui, mas, para poder abordar outras funções, decidi colocá-las.

Como em todos tutoriais que venho fazendo, estarei trabalhando aqui com o Windows 8.1 Professional e o Microsoft Office 365.

Supondo que todos saibam abrir uma planilha de cálculo, vamos ao trabalho.

Ao abrir o Excel, vamos criar um modelo de planilha como o exemplo abaixo.

EXCEL1

Para poupar tempo, já fiz um modelo, para também não precisar colocar mutias imagens neste tutorial.

Vamos deixar por último a linha 1 que se refere ao título CONTROLE DE VENDAS.

Não precisam se preocupar com a formatação agora. Apenas digitem nas células da linha 2 os títulos de cada coluna que são: Mês da Venda, Modelo, Fabricação, Código, Marca, Produto, Preço de Custo, Pedido, Qtde., Valor Unitário, Promoção, Preço de Venda, Valor Total da Venda, Lucre Lucro Total. Redimensionem as colunas para que os títulos fiquem dentro das células.

Agora selecionem a linha 3 até a coluna “O” que é onde acabam os títulos. Após selecionar todos os títulos, clicar no botão de direcionamento que fica ao lado dos botões de alinhamento e depois clicar em Girar o Texto para Cima. Continuando com os títulos selecionados, ao lado do botão de direcionamento clicar no botão Quebra Texto Automaticamente.

Caso não consigam localizar o botão de direcionamento, a imagem abaixo mostra sua localização. E o botão de quebra de texto fica ao seu lado.

EXCEL2

Caso não apareça os botões, mantenha os títulos selecionados, clique com o botão direito do mouse em cima desta seleção e depois clicar em Formatar células. Na guia Alinhamento, existe a opção Quebrar texto automaticamente e mais ao lado direito tem a opção de direção do texto.

EXCEL3

EXCEL4

Agora que criamos os títulos das colunas, podemos selecionar a linha 1 até a coluna “O” que é o limites dos títulos e clicar em Mesclar e centralizar que fica logo abaixo de Quebrar texto automaticamente.

Após as formatações dos títulos e cabeçalhos, vamos formatar as células para que recebam corretamente os valores. Com a tecla “ctrl” pressionada, selecione todos os campos referentes a valores e clique em Moeda, no menu correspondente a formatação das células conforme mostrado na imagem abaixo. Caso não encontrem este menu, podem também clicar com o botão direito do mouse sobre os campos selecionados, clicar em Formatar células e, na guia Número, selecionar a opção moeda e após selecionar esta opção, podem clicar em símbolo e escolher o R$.

EXCEL5

Como aqui no layout deixei tudo centralizado, se quiserem, podem selecionar a planilha inteira e clicar em Alinhar no Meio.

Finalizada a formatação dos campos, vamos começar a criar as regras e condições nas células.

Nas colunas A, B,C,E,F,G,H,I e J, os dados são colocados manualmente.

Na célula D3, referente ao código, vamos colocar a seguinte instrução: =B3&C3. Estamos concatenando as informações das células B3 e C3 para que o código seja a união das informações destas duas células.

Na célula K3, quero que, através de uma condição que vou colocar, apareça se é Preço Normal ou se é Promoção. Então adicionaremos na célula K3 a seguinte condição: =SE(OU(A3=”Janeiro”;A3=”Fevereiro”;A3=”Março”);”Promoção”;”Preço Normal”). Gostaria de explicar esta condição. Se a célula A3 contiver o mês de Janeiro, ou Fevereiro ou ainda Março, será determinado que é Promoção, caso contrário será Preço Normal.

Na célula L3, coloquei a condição =SE(OU(A3=”Janeiro”;A3=”Fevereiro”;A3=”Março”);J3+J3*15%;J3+J3*20%). Significa que, se a célula A3 for um dos meses especificados na condição, terá um desconto promocional, caso contrário será o valor normal de venda.

A fórmula referente à célula M3 é mais simples. Basta multiplicar a quantidade pelo preço de venda, ficando então =L3*I3.

A célula N3 também é uma fórmula simples. Será =L3-G3, a qual você está diminuindo o valor de venda do valor de custo.

A célula O3, apesar de fazer a formula com outro cálculo, faremos da seguinte forma: =(L3-G3)*I3. Significa que estamos subtraindo o Preço de Venda do Preço de Custo e multiplicando pela quantidade. Poderíamos ter feito de outra forma mais simples, mas quis mostrar outra formula e que também é simples de usar.

Agora eu posso estar copiando esta linha  e colocando nas próximas linhas para copiarmos as formulas. Apagamos os valores digitados manualmente para não copiá-los juntos para as outras linhas.

Ao copiar estas fórmulas para as outras linhas, automaticamente as formulas serão alteradas para as suas células correntes.

Espero que tenha ficado bem explicado e que possa estar ajudando a quem necessite.

Abraços

AGRADEÇA AO AUTOR COMPARTILHE!

Luciano Gusso

Mais artigos deste autor »

Formado em Analise e Desenvolvimento de Sistemas, com MBA em Gestão de Projetos.
Trabalhando há mais de 20 anos na área de TI, prestando suporte técnico e consultoria à empresas e usuários finais.


4 Comentários

Deixe seu comentário

Seu endereço de e-mail não será publicado. Campos com * são obrigatórios!

Você pode usar estas tags e atributos de HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">